Windows Install Issue

When I run the initial installation, I am presented with the following, nonspecific, error.

BeyondLabz JS Error

1 Like

I am experiencing this same error, and I know that others in my Chemistry class are as well. I have run the program as an administrator, tried a few different downloads of the client, and have looked at the Beyond Labz youtube channel and watched various videos meant to help with installation. Any guidance would be appreciated! We have our first lab this Thursday and at the moment I have exhausted my ideas for installation.

1 Like

Seems like it is working now. I didn’t do anything to troubleshoot except that I ran the installer through the \AppData\Local\beyond_labz_cc-updater directory. I wonder if it was something on their end. I’m guessing running the installer again should work just fine.

Yes my installer is working now too! I’ll pass this on to my classmates that it should be working now.

Sorry for the issues all! Crazy day over here. What you are seeing is an issue that comes when your Windows Registry is corrupted. Some windows machines stick that installer in that AppData\Local folder and some stick it in AppData\Roaming.
As you could see in the YouTube tutorial I posted, the solution is usually just to track down that installer and install from there. Reach out if you have any more questions!

Hi @heather : I was watching the video on youtube and actually it helped, but later then I wanted to access to the app and it shows that I don’t have “an active license”, but I just downloaded it for a try!
Is there another way to get the trial? :frowning:
Thanks !

Oh I am so very very sorry.
Apparently this an issue with our server provider, so it isn’t even really our fault, but with the internet overload right now this is just not cool. Never happened before today and boom. Ugh.
I’m truly hoping it will be up and running for you soon. I will let you know.
What is happening is that your license isn’t being able to process properly b/c of this server issue . When they get their act together, you will be able to access the labs again no problem.
What crazy times.

@cataiturbe The servers are working again and you should be able to access the program no problem.

Please let me know if you have any issues-

@heather I did it! Now exploring… thanks a lot!

hola, me aparece incompatible con windows 10, me ayudan porfa?

Nuestro programa si funciona con Windows 10. Dime cuales problemas esta teniendo y le puedo ayudar mas!

I have tried to reinstall this program 3 times, now - I cannot get it to open on my windows machine. Do you guys have a tech support phone number I can call to speak to someone. I have been fighting this for several days - it’s frustrating!

@jcormani Oh I’m so sorry you’ve been having such a hard time! Absolutely we are happy to help!
You will find a troubleshooting Windows video on our support page that may very well solve whatever your issue is, or you can submit a ticket with details of your specific problem with the More Help button at the bottom of that screen.

Hope this helps!

Did anyone have an issue with verifying access to a file directory?
“Error writing to file:
Verify that you have access to that directory”

Previously the trial worked well and after getting the activation code. I have been through the support videos for AppData\Local and AppData\Roaming troubleshooting. I have even uninstalled the program and re-installed as well. Is there something I am missing?

Hmm- unfortunately @nrios I’ve seen that error when people have certain anti-virus software installed. Sometimes it blocks the program and makes it stop working.
Do you have AVG or Avast?
You’ll need to create exceptions for the files where our program is. Pull the program out of quarantine if it got stuck in there.
Then you may need to uninstall Virtual ChemLab and reinstall. If you do need to reinstall, it works better if you put your antivirus scanning on a lower level for the time when you are downloading it, just so it doesn’t get blocked on the initial download.
Feel free to reach out with a support ticket on the Support page if you need further help!

Thank you. I did not realize my anti-virus software blocked the program.

I am having the same problem during the installation. The java script error keeps popping up during installation of the sofware. sometimes when installing worksheets or installing cores.

I’m sorry you are having a hard time! Could you please submit a support ticket on and then we can dive into fixing your actual problem?
My guess is that you are going to need to uninstall with Add or Remove Programs and then you need to go into your hidden folders and delete the beyond_labz_cc folder in the AppData/Local/Programs folder.
That should allow you to reinstall the Beyond Labz program.
Unless your issue that you are describing is just with installing the individual lab benches- in that case- don’t uninstall Beyond Labz- lets just fix the individual lab installs.
I’ll help you over with a support ticket as soon as you can submit one!

I am having issues downloading VirtualChemLab on my BeyondLabz on Windows. I have watched the videos on how it can be fixed, but it continually does not work. I have closed my BeyondLabz and went to my files and went to the hidden folders and saw what I needed, did what was said, but still did not work. What should I do now because I am a student who is gonna need this application soon this semester?

I’m sorry you are having a hard time!
Are you in the main admin user profile on your computer or a separate user profile?
That’s my guess of what is wrong- it is probably installing your lab in the wrong user profile. Feel free to reach out to and I can walk you through how to deal with that issue.
Or if you are the main admin on your computer, please tell me what you saw when you double clicked on the virtualchemlab.msi folder. Did an installation box pop up?