Mac troubleshooting helpp

I’m having mac installation issues that aren’t addressed in the help videos that beyondlabz have posted…
not sure if there is a customer help line but the issue is simply:

when i downloaded and purchased the an activation code, the lab that i wanted to download (organic chem) from the beyondlabz main screen was already downloaded.
when i clicked “open”, nothing comes up.

I went through the finder>home>library>application support>click on beyondlabz>click on public…and when i open ‘public’, there’s no download folder. just “assets” and something called “cc.db”. not sure what to do, i’ve restarted my comp, the program itself, and even deleted beyondlabz and redownloaded … same result.

if anyone has a clue please let me know! :pray:

Hmm @chinyeluasher I’ve seen this before. My guess is that you have an old copy for Virtual Organic in your Applications Folder. Are you a UNE student?
Close Beyond Labz w/ the Exit arrow in the top right hand corner (not the X).
Then delete the old Virtual ChemLab Organic icon from your Applications folder.
Open BeyondLabz again & now you’ll be able to download Organic fresh.
You are always welcome to reach out to us on our Support page too!
Please let me know if you need any more help.

it worked!! (Yes I am a UNE student)
Dancing for joy. Thank you!!

@chinyeluasher I’m glad that worked! You just needed a new copy of Organic.
Good luck in the lab!