ChemLab will download but not open

A student is having trouble getting the Chemistry Lab to open once downloaded. He has watched the troubleshooting video and the tips did not work. He uninstalled the Client and reinstalled but the downloaded room still does not open. Do you have any advice for him?
Thank you!

@JaimieG Feel free to ask them to submit a support ticket on our support page and we can dive into specifics.
Are you saying that they have managed to Download the Chemistry lab and it has switched to Open, but when they click on Open it doesn’t do anything? Or that they aren’t being able to fully download? Are there any error messages popping up?

Thanks Heather!
From my understanding he downloaded the Chemistry Lab and when it switched to open, it does not do anything. He did not indicate that he was getting error messages.

@JaimieG
I’ve seen that error occasionally when users haven’t updated or restarted their computers in a long time. Sometimes there are just some operating system updates that need to process.
There is also a chance if they are on a windows machine and have an anti-virus software like AVG or Avast, it could have blocked them from being able to open the program. In that case, they’d need to create some exceptions for our program in the anti-virus software, and occasionally they’d need to uninstall and reinstall just the lab portion, not the entire program.
Hope that helps!

Hello Jaimie, I’m having an issue with the Chemistry lab; I can’t get it to download, and I have tried both step 1 and 2 on the troubleshoot video, please help.

@dgabriel I’m sorry you are having a hard time! Did you find the virtual chemistry installer in the hidden folders? What happened when you clicked it?

I the chemistry lab, it would fully complete the download bar and then a dial box would pop up with lengthy text that I didn’t bother to read because it was very long (potentially could be my solution), but when I returned to the app instead of saying open it still says download like nothing ever happened.

@dgabriel
Don’t worry- that box probably wasn’t your solution :slight_smile:
I’m still not entirely clear- did you find the virtualchemlab.msi installer in the hidden folder? If you did, and that didn’t install it for you, go through the steps below. If you didn’t find it yet, please explain what you are seeing when you search for that file.

Will you close Beyond Labz with the exit arrow in the top right corner and then open your Add or Remove Programs menu and try uninstalling Virtual ChemLab from there (not Beyond Labz, scroll way down and see if you have Virtual ChemLab).
Then go into your C://Users/YourUserName/AppData/Roaming/beyond_labz_cc/public/install
and delete the old installer virtualchemlab.msi
Then reopen Beyond Labz and see what happens when you click Download for Chemistry again.
If that doesn’t install it, try reopening that folder that I included the path for above and see what happens when you double click on the installer this time.

Let me know how that goes!

Thank you Heather, your directions to get to the file that needed to be deleted were perfect. Sorry about the delayed satisfaction.

I’m having the same issue: the chemistry lab will download, but when I click on the “open” button, it doesn’t do anything. I’m on a MacBook Pro, updated to the latest OS (Catalina 10.15.4). I have tried restarting my computer, as well as uninstalling and reinstalling BeyondLabz. There aren’t any error messages popping up. Any help would be appreciated.

@artemis
I’m sorry you are having a hard time. On Macs there are a couple different things to check than on Windows machines.

  1. Is the Virtual ChemLab icon in the Applications folder? If not, please drag it there.
  2. If the Virtual ChemLab icon is in the Applications folder, try double clicking on the icon to open it. What happens?

Feel free to submit your answers here, or submit a support ticket directly to me from the Support page.

@heather
Thank you for your suggestions. The Virtual Chemlab icon is in the applications folder, but it’s crossed out:


When I try to open it, I get the following error message: “Virtual ChemLab needs to be updated. The developer of this app needs to update it to work with this version of MacOS. Contact the developer for more information.”

I think this error means the app is 32-bit, and the Catalina OS can only run 64 bit apps. If this is the case, I might just have to find a different computer. Is there anything else I can do?

@artemis
Ok, that icon definitely has issues! That would be why its not working!
Our program is definitely 64 bit, so you don’t need to find a different computer.
Please just drag that Virtual ChemLab icon into the trash.
Exit the Beyond Labz program with the Exit arrow in the top right corner.
Then reopen the Beyond Labz program and you should be able to redownload Chemistry.
Make sure to drag Virtual ChemLab into the Applications folder if it doesn’t go there directly.
Let me know how that goes!

1 Like

@heather
It works now. Thank you! :smiley:

I have completed download but the downloads want open

@w1253661 Carla- did you see I responded to you from the support page? I’d be happy to help you get them running. Happy to hop on a video call or send you more directions in an email. Did the chemistry button switch to Open yet or does it still say Download?

Thank you!! You were so helpful!!!

@aneres
you’re welcome! thanks for saying thank you. it makes a difference.

Hi Im having trouble with the Chemistry Lab. I press download and the percentage goes until 100% then a Windows Installer Opens with a white screen and text and I just click OK, then when I return to the BeyondLabz the download button is still there for Chemistry.

@Triplemav_15
Ok, so this sounds like a standard Windows issue. Here is the fix:

Directions on how to solve this (also outlined in the Youtube tutorial here)

  1. Exit the Beyond Labz client by clicking the white arrow in the top right corner.
  2. Open a File Explorer, open the C drive, then the Users Folder, then Your UserName. Then select the View tab at the top and check the box for Hidden Items. Now you will have a folder called AppData. Open that folder. Now open the Roaming folder and use the search box to find:
  • Chemistry, look for virtualchemlab.msi

  • The file will most likely be in this location: c:\users\YourUserName\AppData\Roaming\beyond_labz_cc\public\install

  1. When you find it the msi file, double click on it to launch the installer.
  2. Restart the Beyond Labz client and Chemistry should say Open.

If you are not the Admin user on your computer, your lab program will probably have installed in the Admin user’s account and you’ll need to move it. Let us know and we can help you.

If you are the Admin user on your computer and this doesn’t work, delete that hidden installer file that didn’t work and go into your computer Settings menu and Add or Remove Programs menu and Uninstall the Virtual ChemLab program (not Beyond Labz). Then try re-downloading a new lab installer from the Beyond Labz program and start over again.

Let us know if you need further assistance.